poj 1654 在方格中求多边形的面积


Description

You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2. 

For example, this is a legal polygon to be computed and its area is 2.5: 

Input

The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.

Output

For each polygon, print its area on a single line.

Sample Input

4
5
825
6725
6244865

Sample Output

0
0
0.5
2

Area=1/2*abs((x0*y1-x1*y0)+(x1*y2-x2*y1)...+(xn*yn-1-xn-1*yn)+(xn*y0-x0*yn))注意:没有构成封闭的多边形时不成立

把相邻两点和原点组成一个三角形,而总面积是这n个三角形面积的和,而三角形面积是两个相邻边向量的叉积

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<string>
#include<algorithm>
#define LL long long
#define inf 0x3f3f3f3f
LL cross(LL x1,LL y1,LL x2,LL y2)
{
    return x1*y2-y1*x2;
}
int dx[15]={0,-1,0,1,-1,0,1,-1,0,1};
int dy[15]={0,-1,-1,-1,0,0,0,1,1,1};
using namespace std;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        string str;
        cin>>str;
        if(str.length()<3)
        {
            cout<<0<<endl;
            continue;
        }
        LL x=0,y=0;
        LL s=0;
        for(int i=0;i<=str.length()-1;i++)
        {
            if(str[i]-'0'=='5')
                break;
            int xx=x+dx[str[i]-'0'];
            int yy=y+dy[str[i]-'0'];
            s+=cross(xx,yy,x,y);
            x=xx;
            y=yy;
        }
        if(s<0) s=(-1)*s;
        if(s%2==0)
            cout<<s/2<<endl;
        else
            cout<<s/2<<".5"<<endl;
    }
    return 0;
}


你可能感兴趣的:(方格上求多边形的面积)