题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5045
题面:
Contest
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1237 Accepted Submission(s): 494
Problem Description
In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems.
On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more.
Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems.
For each problem, each student has a certain probability that correct solve. If the i
th student solve the j
th problem, the probability of correct solve is P
ij .
At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal.
You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability
Input
The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve.
The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively.
The next N lines, each lines contains M real numbers between 0 and 1 , the j
th number in the i
th line is P
ij .
Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.
Sample Input
1
2 3
0.6 0.3 0.4
0.3 0.7 0.9
Sample Output
Source
2014 ACM/ICPC Asia Regional Shanghai Online
题目大意:
给定n个人分别完成m个编程问题的成功率,问怎样分配可以使得最终期望的AC问题数最多。有一个限制,(每个人耗时1小时完成1道题)任意时刻,任何两个选手间的耗时数差不能超过1个小时。
解题:
突破点在于耗时数差不能超过1个小时,我是没想到用01表示当前每个选手的答题数量减去一个基准值,如果想到了就很好写了。感觉状态压缩dp的精髓在于人为地筛选出一些合法的状态,减少盲目搜索,从而提高效率。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <set>
using namespace std;
int n,m,t;
//dp[i][j]表示第i位答题状态为j的最优值,posi存的是每个选手答每道题的正确概率
double dp[1010][1050],posi[11][1010];
int main()
{
int tmp,lim;
scanf("%d",&t);
double ans,temp;
for(int i=1;i<=t;i++)
{
//读入
scanf("%d%d",&n,&m);
memset(dp,0,sizeof(dp));
for(int j=1;j<=n;j++)
for(int k=1;k<=m;k++)
scanf("%lf",&posi[j][k]);
//两个set配合使用记录前一步合法状态
set <int> s;
set <int> ts;
set <int> :: iterator it;
//初始化
for(int j=0;j<n;j++)
{
dp[1][1<<j]=posi[j+1][1];
s.insert(1<<j);
}
for(int j=2;j<=m;j++)
{
ts.clear();
//枚举前一步的合法状态
for(it=s.begin();it!=s.end();it++)
{
for(int p=0;p<n;p++)
{
//如果前一步没取p的话,那么tmp值为0
tmp=(1<<p)&(*it);
if(!tmp)
{
//现在tmp为取了p之后的状态
tmp=(*it)+(1<<p);
//如果已经全部变成1了,那么清零
if(tmp==(1<<n)-1)
tmp=0;
//将此时的状态存入ts,同时排重,否则会超时
ts.insert(tmp);
//j位取p的值
temp=dp[j-1][*it]+posi[p+1][j];
//优于原值,则更新
if(temp>dp[j][tmp])
dp[j][tmp]=temp;
}
}
}
//将ts的内容放入s
s.clear();
for(it=ts.begin();it!=ts.end();it++)
s.insert(*it);
}
lim=(1<<n)-1;
ans=0.0;
//遍历最后一个位置的最优值
for(int j=0;j<=lim;j++)
{
if(dp[m][j]>ans)
ans=dp[m][j];
}
printf("Case #%d: %.5lf\n",i,ans);
}
return 0;
}