POJ 2081 Recaman's Sequence

Recaman's Sequence
Time Limit:3000MS     Memory Limit:60000KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

The Recaman's sequence is defined by a0 = 0 ; for m > 0, a  m = a  m−1 − m if the rsulting a  m is positive and not already in the sequence, otherwise a  m = a m−1 + m. 
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ... 
Given k, your task is to calculate a  k.

Input

The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000. 
The last line contains an integer −1, which should not be processed.

Output

For each k given in the input, print one line containing a  k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

暴力搜索:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int a[500010],b[4000000];

int main(){
	int n,i;
	a[0]=0;
	b[0]=1;
	for(i=1;i<=500000;i++){
		if(a[i-1]-i>0&&!b[a[i-1]-i]){
			a[i]=a[i-1]-i;
			b[a[i]]=1;
		}
		else {
			a[i]=a[i-1]+i;
			b[a[i]]=1;
		}
	}
	
	while(scanf("%d",&n)&&n!=-1){
		printf("%d\n",a[n]);
	}
}



你可能感兴趣的:(POJ 2081 Recaman's Sequence)