打表-HDOJ-5347-MZL's chemistry

MZL’s chemistry

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 711 Accepted Submission(s): 496

Problem Description
MZL define F(X) as the first ionization energy of the chemical element X

Now he get two chemical elements U,V,given as their atomic number,he wants to compare F(U) and F(V)

It is guaranteed that atomic numbers belongs to the given set:{1,2,3,4,..18,35,36,53,54,85,86}

It is guaranteed the two atomic numbers is either in the same period or in the same group

It is guaranteed that x≠y

Input
There are several test cases

For each test case,there are two numbers u,v,means the atomic numbers of the two element

Output
For each test case,if F(u)>F(v),print “FIRST BIGGER”,else print”SECOND BIGGER”

Sample Input
1 2
5 3

Sample Output
SECOND BIGGER
FIRST BIGGER

直接打表。。。太水了不说了。

//
// main.cpp
// 150804-1005
//
// Created by 袁子涵 on 15/8/4.
// Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>

using namespace std;

int a,b;

int s[25]={0,1312,2372,520,899,800,1086,1402,1313,1681,2080,495,737,577,786,1011,999,1251,1520,1140,1351,1008,1170,890,1037};

int main(int argc, const char * argv[]) {
    while (scanf("%d %d",&a,&b)!=EOF) {
        if (s[a]>s[b]) {
            printf("FIRST BIGGER\n");
        }
        else
        {
            printf("SECOND BIGGER\n");
        }
    }
    return 0;
}

你可能感兴趣的:(c)