hduoj4883!【数学】

/*TIANKENG’s restaurant
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 675    Accepted Submission(s): 320


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. 
Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one 
chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to
 prepare so that every customer can take a seat when arriving the restaurant?
 
Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive 
integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi
(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving 
group can be arranged to take their seats if the seats are enough.

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.

Sample Input
2
2
6 08:00 09:00
5 08:59 09:59
2
6 08:00 09:00
5 09:00 10:00

Sample Output
11
6
 
Source
BestCoder Round #2 
*/
#include<stdio.h>
#include<string.h>
int a[1441];
int main()
{
	int num, n, m , i, j, k, e, f;
	scanf("%d", &n);
	while(n--)
	{
		memset(a, 0, sizeof(a));
		scanf("%d", &m);
		for(i = 0; i  < m; i++)
		{
			scanf("%d %d:%d %d:%d", &num, &j, &k, &e, &f);
			a[j * 60 + k] += num;
			a[e * 60 + f] -= num;
		}
		int sum = 0,ans = 0;
		for(i = 0; i  < 1441; i++)
		{
			sum += a[i];
			if(sum > ans)
			ans = sum;
		}
		printf("%d\n", ans);
	}
	return 0;
}


区间选点

先将基本单位化作分钟,再开个一天1440分钟的数组,保存每个点的客人数,再进行求和,求出过程中的最大值。

关键:理解为什么区间上求和取最大值就是结果。

你可能感兴趣的:(c)