HDOJ1305 Immediate Decodability

最近在学字典树

还是同样的思路,要注意每个case要清树。。

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1305

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2166    Accepted Submission(s): 1120


Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 

Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 

Sample Input
   
   
   
   
01 10 0010 0000 9 01 10 010 0000 9
 

Sample Output
   
   
   
   
Set 1 is immediately decodable Set 2 is not immediately decodable
 
代码如下:
#include<iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
using namespace std;
typedef struct trie{
    trie* next[2];
    bool used;
    bool isend;
};
int ans=1;
trie* newnode()
{
    trie* a=new trie;
    a->isend=false;
    a->used=false;
    a->next[0]=a->next[1]=NULL;
    return a;
}
trie* Insert(trie* root,char a[])
{
    trie* use=root;
    for(int i=0;a[i];i++)
    {
        if(use->next[a[i]-'0']==NULL)
            use->next[a[i]-'0']=newnode();
        if(use->next[a[i]-'0']->isend)
            ans=0;
        if(i!=0)
            use->used=true;
        use=use->next[a[i]-'0'];
    }
    if(use->isend||use->used)
        ans=0;
    use->isend=true;
    use->used=true;
    return root;
}
void Clear(trie* root)
{
    if(root->next[0]!=NULL)
      Clear(root->next[0]);
    if(root->next[1]!=NULL)
      Clear(root->next[1]);
    root->isend=false;
    root->used=false;
    root=NULL;
    delete root;
}
int main()
{
//    freopen("D://input.txt","r",stdin);
    char input[12];
    int kase=1;
    trie* root=newnode();
    while(scanf("%s",input)!=EOF)
    {
        if(input[0]=='9'){
            Clear(root);
            if(ans)
                printf("Set %d is immediately decodable\n",kase++);
            else
                printf("Set %d is not immediately decodable\n",kase++);
            ans=1;
        }
        else
            Insert(root,input);
    }
    return 0;
}



你可能感兴趣的:(HDOJ1305 Immediate Decodability)