HDU 1597 find the nth digit


find the nth digit
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 1597

Description

假设: 
S1 = 1 
S2 = 12 
S3 = 123 
S4 = 1234 
......... 
S9 = 123456789 
S10 = 1234567891 
S11 = 12345678912 
............ 
S18 = 123456789123456789 
.................. 
现在我们把所有的串连接起来 
S = 1121231234.......123456789123456789112345678912......... 
那么你能告诉我在S串中的第N个数字是多少吗? 
 

Input

输入首先是一个数字K,代表有K次询问。 
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 

Output

对于每个N,输出S中第N个对应的数字. 
 

Sample Input

      
      
      
      
6 1 2 3 4 5 10
 

Sample Output

      
      
      
      
1 1 2 1 2 4

一点一点的找   


#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
int a[46] = {1,1,2,1,2,3,1,2,3,4,1,2,3,4,5,1,2,3,4,5,6,1,2,3,4,5,6,7,1,2,3,4,5,6,7,8,1,2,3,4,5,6,7,8,9};

int main(){
	int k;
	scanf("%d", &k);
	while(k--){
		long long n;
		scanf("%d", &n);
		int flag = 0;
		if(n <= 45)
			cout << a[n - 1] << endl;
		else {
			n = n - 45;
			for(int i = 1; ; ++i){
				for(int j = 1; j <= 9; ++j){
					if(n <= (9 * i) + j){
						if(n % 9 == 0)
							cout << "9" << endl;
						else
							cout << n % 9 << endl;
						flag = 1;
						break;
					}
					else {
						n -= (9 * i + j);
					}
					//cout << "N : " << n << endl;
				}
				if(flag == 1)
					break;
			}	
		}
	}
	return 0;
}





你可能感兴趣的:(find,N,HDU,the,1597)