病毒侵袭持续中 (HDU_3065) AC自动机

病毒侵袭持续中

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10145    Accepted Submission(s): 3564


Problem Description
小t非常感谢大家帮忙解决了他的上一个问题。然而病毒侵袭持续中。在小t的不懈努力下,他发现了网路中的“万恶之源”。这是一个庞大的病毒网站,他有着好多好多的病毒,但是这个网站包含的病毒很奇怪,这些病毒的特征码很短,而且只包含“英文大写字符”。当然小t好想好想为民除害,但是小t从来不打没有准备的战争。知己知彼,百战不殆,小t首先要做的是知道这个病毒网站特征:包含多少不同的病毒,每种病毒出现了多少次。大家能再帮帮他吗?
 

Input
第一行,一个整数N(1<=N<=1000),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在1—50之间,并且只包含“英文大写字符”。任意两个病毒特征码,不会完全相同。
在这之后一行,表示“万恶之源”网站源码,源码字符串长度在2000000之内。字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
按以下格式每行一个,输出每个病毒出现次数。未出现的病毒不需要输出。
病毒特征码: 出现次数
冒号后有一个空格,按病毒特征码的输入顺序进行输出。
 

Sample Input
   
   
   
   
3 AA BB CC ooxxCC%dAAAoen....END
 

Sample Output
   
   
   
   
AA: 2 CC: 1
Hint
Hit: 题目描述中没有被提及的所有情况都应该进行考虑。比如两个病毒特征码可能有相互包含或者有重叠的特征码段。 计数策略也可一定程度上从Sample中推测。
 




题目大意:给出一些模式串,以及一串主串,求问这些模式串在主串中出现的次数;


解题思路:AC自动机。


代码如下:

 #include"iostream"
 #include"cstdio"
 #include"cstring"
 #include"queue"
 using namespace std;
 const int maxn = 2000005;
 const int maxk = 128;
 char str[maxn], word[1005][55];
 
 struct Trie{
 	int next[1005*50][maxk], fail[1005*50], end[1005*50];
 	int root, L;
 	
 	int newnode(){
 		for(int i = 0;i < maxk;i ++) 
			next[L][i] = -1;
		end[L ++] = -1;
		return L - 1;
	 }
	 
	 void init(){
	 	L = 0;
	 	root = newnode();
	 }
	 
 	void Insert(char *s, int id){
 		int len = strlen(s);
 		int now = root;
 		for(int i = 0;i < len;i ++){
 			if(next[now][s[i]] == -1)
 				next[now][s[i]] = newnode();
 			now = next[now][s[i]];
		 }
 		end[now] = id;
	 }
	 
	 void Getfail(){
	 	queue<int> Q;
	 	fail[root] = root;
	 	for(int i = 0;i < maxk;i ++){
	 		if(next[root][i] == -1) 
			 	next[root][i] = root;
	 		else{
	 			fail[next[root][i]] = root;
	 			Q.push(next[root][i]);
			 }
		 }
		 while(!Q.empty()){
			int now = Q.front();
			Q.pop();
			for(int i = 0;i < maxk;i ++){
				if(next[now][i] == -1)
					next[now][i] = next[fail[now]][i];	
				else{
					fail[next[now][i]] = next[fail[now]][i];
					Q.push(next[now][i]);
				}
			}
		 }
	 }
	 
	 int cnt[1005];
	 void Query(){
	 	int len = strlen(str);
	 	int now = root;
	 	memset(cnt, 0, sizeof(cnt));
	 	for(int i = 0, k = 0;i < len;i ++){
	 		now = next[now][str[i]];
	 		int temp = now;
	 		while(temp != root){
	 			if(end[temp] != -1)
	 				cnt[end[temp]] ++;
				 temp = fail[temp];
			 }
		}
	 }
 	
 };
 
Trie ac;

int main(){
	int n;
	while(scanf("%d",&n) == 1){
		ac.init();
		for(int i = 1;i <= n;i ++){
			scanf("%s",word[i]);
			ac.Insert(word[i], i);
		}
		ac.Getfail();
		scanf("%s",str);
		ac.Query();
		for(int i = 1;i <= n;i ++)
			if(ac.cnt[i]) printf("%s: %d\n",word[i],ac.cnt[i]);
	}
	return 0;
}
 
 
 
 
 
 

你可能感兴趣的:(AC自动机)