几何题,二分法 fz1148

        几何问题,求出寻找宽度的公式。。

         二分法暴力寻找

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?


几何题,二分法 fz1148_第1张图片

 Input

Each line of input contains three positive floating point numbers giving the values of  xy, and  c.

 Output

For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

 Sample Input

30 40 1012.619429 8.163332 310 10 310 10 1

 Sample Output

26.0337.0008.0009.798
#include<stdio.h>
#include<math.h>
#define Min(a,b) a<=b?a:b
double x,y,c;
double ans(double w)
{
    return 1-c/sqrt(y*y-w*w)-c/sqrt(x*x-w*w);
}
int main()
{

    while(scanf("%lf %lf %lf",&x,&y,&c)!=EOF)
    {
        double l=0,sum,r=Min(x,y);

        while(r-l>10e-8)
        {
            sum=(l+r)/2;
            if(ans(sum)>0)
            {
                l=sum;
            }
            else
                r=sum;

        }
        //printf("###\n");
        printf("%.3lf\n",sum);
    }
}


你可能感兴趣的:(几何题,二分法 fz1148)