HDU 1671 Phone List(字典树)

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14453    Accepted Submission(s): 4863


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
   
   
   
   
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
   
   
   
   
NO YES
 
题意就是找一个串的前缀是否是其他的串,如果有的话就输出NO,没有的话就输出YES,用字典树很方便
代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int mark;
struct trie
{
    int vis;
    trie *Next[11];
    trie()
    {
        vis = 0;
        memset(Next, 0, sizeof(Next));
    }
};
trie *root;
void init(char *num)
{
    trie *p;
    p = root;
    for(int i = 0; num[i]; i++)
    {
        int id =num[i] - '0';
        if(p->Next[id] == NULL) p->Next[id] = new trie;
        if(p->vis)//当前串含有其它串
            mark = 1;
        if(mark)
            break;
        p = p->Next[id];
    }
    p->vis = 1;
    for(int i = 0; i<10; i++)
    {
        if(p->Next[i] != NULL)//看当前串是其他串的前缀否
            mark = 1;
    }
}
void del(trie *p)
{
    for(int i = 0; i<10; i++)
        if(p->Next[i] != NULL)
            del(p->Next[i]);
    free(p);
}
int main()
{
    int t, n;
    char num[15];
    cin>>t;
    while(t--)
    {
        root = new trie;
        cin>>n;
        mark = 0;
        while(n--)
        {
            scanf("%s", num);
            if(!mark)
                init(num);
        }
        if(mark)
            printf("NO\n");
        else
            printf("YES\n");
        del(root);//释放内存,要不然会超内存
    }
}



你可能感兴趣的:(HDU 1671 Phone List(字典树))