Keywords Search
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 49346 Accepted Submission(s): 15795
Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
Output
Print how many keywords are contained in the description.
Sample Input
1
5
she
he
say
shr
her
yasherhs
Sample Output
Author
Wiskey
题目大意:给出一些单词及一片个长串,求问单词在长串出现的次数;
解题思路:AC自动机,注意单词可能重复出现。
代码如下:
#include"iostream"
#include"cstdio"
#include"cstring"
#include"queue"
using namespace std;
const int maxn = 1000005;
const int maxk = 26;
char str[maxn];
struct Trie{
int next[10005*50][maxk], fail[10005*50], end[10005*50];
int root, L;
int newnode(){
for(int i = 0;i < maxk;i ++)
next[L][i] = -1;
end[L ++] = 0;
return L - 1;
}
void init(){
memset(end,0,sizeof(end));
L = 0;
root = newnode();
}
void Insert(char *s){
int len = strlen(s);
int now = root;
for(int i = 0, k = 0;i < len;i ++){
k = s[i] - 'a';
if(next[now][k] == -1)
next[now][k] = newnode();
now = next[now][k];
}
end[now] ++;
}
void Getfail(){
queue<int> Q;
fail[root] = root;
for(int i = 0;i < maxk;i ++){
if(next[root][i] == -1)
next[root][i] = root;
else{
fail[next[root][i]] = root;
Q.push(next[root][i]);
}
}
while(!Q.empty()){
int now = Q.front();
Q.pop();
for(int i = 0;i < maxk;i ++){
if(next[now][i] == -1)
next[now][i] = next[fail[now]][i];
else{
fail[next[now][i]] = next[fail[now]][i];
Q.push(next[now][i]);
}
}
}
}
int Query(){
int cnt;
int len = strlen(str);
int now = root;
cnt = 0;
for(int i = 0, k = 0;i < len;i ++){
k = str[i] - 'a';
now = next[now][k];
int temp = now;
while(temp != root){
cnt += end[temp];
end[temp] = 0;
temp = fail[temp];
}
}
return cnt;
}
};
Trie ac;
int main(){
int n, T;
char s[55];
scanf("%d",&T);
while(T --){
ac.init();
scanf("%d",&n);
for(int i = 1;i <= n;i ++){
scanf("%s",s);
ac.Insert(s);
}
ac.Getfail();
scanf("%s",str);
printf("%d\n",ac.Query());
}
return 0;
}