zoj--3872--Beauty of Array(思维)


Beauty of Array Time Limit: 2 Seconds        Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38


给你一个有n个数字的序列,所有子序列里的不一样的数字的和表示这个序列的美丽度,求每一个序列的美丽度

因为数字可能会很多,所以不可以两重for,记录一个数字最后一次出现的位置,要到达一个数字,那就必须达到他前一个数字,但是这个数字如果在之前已经过了,那么有一段就不需要了,因为这个数字已经累加在里边,只需要把这个数给没有用过的序列就行,其实也就是计算每一个数字的权值


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<set>
#include<vector>
using namespace std;
long long sum[100000+100],pre[100000+100];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		memset(sum,0,sizeof(sum));
		memset(pre,0,sizeof(pre));
		long long ans=0;
		for(long long i=1;i<=n;i++)
		{
			long long x;
			scanf("%lld",&x);
			sum[i]=sum[i-1]+(i-pre[x])*x;
			pre[x]=i;
			ans+=sum[i];
		}
		printf("%lld\n",ans);
	}
	return 0;
}


你可能感兴趣的:(zoj--3872--Beauty of Array(思维))