HDU - 5202 - Rikka with string (DFS)

Rikka with string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 214    Accepted Submission(s): 109


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:


One day, Yuta got a string which contains n letters but Rikka lost it in accident. Now they want to recover the string. Yuta remembers that the string only contains lowercase letters and it is not a palindrome string. Unfortunately he cannot remember some letters. Can you help him recover the string?


It is too difficult for Rikka. Can you help her?
 

Input
This problem has multi test cases (no more than  20 ). For each test case, The first line contains a number  n(1n1000) . The next line contains an n-length string which only contains lowercase letters and ‘?’ – the place which Yuta is not sure.
 

Output
For each test cases print a n-length string – the string you come up with. In the case where more than one string exists, print the lexicographically first one. In the case where no such string exists, output “QwQ”.
 

Sample Input
   
   
   
   
5 a?bb? 3 aaa
 

Sample Output
   
   
   
   
aabba QwQ
 

Source
BestCoder Round #37 ($)
 




AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define LL long long 
using namespace std;

char str[1005];
int len;
int flag;

int judge() {
    for(int i = 0; i <= len / 2; i++) {
        if(str[i] != str[len - i - 1]) return 1;
    }
    return 0;
}

void dfs(int x) {
    if(flag == 0) return;
    if(x == len) {
        if(judge()) {
            printf("%s\n", str);
            flag = 0;
        }
        return;
    }
    if(str[x] <= 'z' && str[x] >= 'a') {
        dfs(x + 1);
        return;
    }
    
    if(str[x] == '?') {
        for(int i = 'a'; i <= 'z'; i++) {
            str[x] = (char)i;
            dfs(x + 1);
            str[x] = '?';
        }
    }
}

int main() {
    int n;
    while(scanf("%d", &n) != EOF) {
        scanf("%s", str);
        len = strlen(str);
        flag = 1;
        dfs(0);
        if(flag) {
            printf("QwQ\n");
        }
    }
    return 0;
}










你可能感兴趣的:(ACM,HDU)