hduoj1395!【水题】

/*2^x mod n = 1
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11690    Accepted Submission(s): 3640


Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input
One positive integer on each line, the value of n.

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input
2
5
 
Sample Output
2^? mod 2 = 1
2^4 mod 5 = 1
 
Author
MA, Xiao
 
Source
ZOJ Monthly, February 2003 
*/
#include<stdio.h>
int main()
{
	int n , i, j;
	while(scanf("%d", &n) != EOF)
	{
		if( !(n&1) || n == 1)
		printf("2^? mod %d = 1\n", n);
		else
		{
			j = 1;
			for(i = 1; ; i++)
			{
				j *= 2;
				j %= n;
				if(j == 1)
				break;
			}
			printf("2^%d mod %d = 1\n", i, n);
		}
	}
	return 0;
}

题意:给出一个n,求最小的x使得2^x mod n =  1

思路:当n为奇数时,必定存在一个2的i次方 mod n = 1.当n为偶数时,由于偶数对偶数取余,余数必定是偶数,所以偶数不存在,还有当n=1时也不存在(特殊数字)。

你可能感兴趣的:(c)