hduoj!1086!【数学】

/*You can Solve a Geometry Problem too
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7304    Accepted Submission(s): 3552

Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the 
experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, 
not a contest :)
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments
 intersect at the same point.

Note:
You can assume that two segments would not intersect at more than one point. 

Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes 
one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the number of intersections, and one line one case.

Sample Input
2
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.00
3
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.000
0.00 0.00 1.00 0.00
0
 

Sample Output
1
3
 
Author
lcy
 
*/
#include<stdio.h>
int isintersect(double x1, double y1, double x2, double y2, double x3, double y3, double x4, double y4)
{
	double ac1 , ac2, bc1, bc2, ad1, ad2, bd1, bd2;
	ac1 = x3 - x1;
	ac2 = y3 - y1;
	bc1 = x3 - x2;
	bc2 = y3 - y2;
	ad1 = x4 - x1;
	ad2 = y4 - y1;
	bd1 = x4 - x2;
	bd2 = y4 - y2;
	if( (ac1*bc2 - ac2*bc1) * (ad1*bd2 - ad2*bd1) <= 0)
		;
	else
	return 0;
	double ca1, ca2, da1, da2, cb1, cb2, db1, db2;
	ca1 = x1 - x3;
	ca2 = y1 - y3;
	da1 = x1 - x4;
	da2 = y1 - y4;
	cb1 = x2 - x3;
	cb2 = y2 - y3;
	db1 = x2 - x4;
	db2 = y2 - y4;
	if( (ca1*da2 - ca2*da1) * (cb1*db2 - cb2*db1) <= 0)
	return 1;
	else 
	return 0;
}
int main()
{
	int n, m, i, j, k;
	double s[110][4];
	while(scanf("%d",&n ) != EOF && n)
	{
		for(i = 0 ; i < n; i++)
		scanf("%lf%lf%lf%lf", &s[i][0], &s[i][1], &s[i][2], &s[i][3]);
		m = 0;
		for(i = 0; i < n-1; i++)
		{
			for(j = i+1; j < n; j++)
			if( isintersect(s[i][0] , s[i][1], s[i][2] , s[i][3] , s[j][0] , s[j][1] , s[j][2] , s[j][3]) )
				m++;
		}
		printf("%d\n", m);
	}
	return 0;
}


题意:给出n条线段,判断交点数。

判断直线是否相交用向量的叉积公式ACxBC*ADxBD <= 0,则CD在AB的两侧,同理判断AB在CD的两侧。

你可能感兴趣的:(c)