1040. Longest Symmetric String (25)

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:

11


IDEA

1.遍历每个字符,以它为中心,判断:

若回文为奇数个数,则判断s[i] 两侧字符是否相等

若回文为偶数个数,则判断s[i]与右侧字符是否相等

1040. Longest Symmetric String (25)_第1张图片

CODE

#include<iostream>
#include<cstring>
using namespace std;
int main(){
	string s;
	getline(cin,s);
	int max=1;
	for(int i=0;i<s.size();i++){
		int p=i-1,q=i+1;
		while(p>=0&&q<s.size()){//回文是奇数个 
			if(s[p]==s[q]){
				if(max<q-p+1){
					max=q-p+1;
				}
				p--;
				q++;
			}else{
				break;
			}
		}
	}
	for(int i=0;i<s.size();i++){//回文是偶数 
		int p=i,q=i+1;
		while(p>=0&&q<s.size()){
			if(s[p]==s[q]){
				if(max<q-p+1){
					max=q-p+1;
				}
				p--;
				q++;
			}else{
				break;
			}
		}
	} 
	cout<<max; 
	return 0;
}


你可能感兴趣的:(pat,字符串中的回文)