HDOJ 1062 Text Reverse

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20644    Accepted Submission(s): 7887


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
   
   
   
   
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
   
   
   
   
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:   1073  1039  1040  1088  1002

#include<stdio.h>
#include<string.h>
void tran(char a[1000]){
	int len,i;
	char temp;
	len=strlen(a);
	for(i=0;i<len/2;i++){ //一定是i<len/2,切记 
		temp=a[i]; a[i]=a[len-i-1]; a[len-i-1]=temp;
	}
}      //翻转 
int main(){
	int n,i,len,t;
	char a[1000],b[1000];
	scanf("%d",&n);
	getchar();  //接收 \n 
	while(n--){
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		gets(a);
		len=strlen(a);
		t=0;
		for(i=0;;i++){   //终止条件是 i==len-1
			if(a[i]!=' '){
				b[i-t]=a[i];
			}  //在不等于字符串长度的情况下,遇到空格就是一个子串的结束 
			else {
				tran(b);
				printf("%s ",b);
				t=i+1;
				memset(b,0,sizeof(b));
			}
			if(i==len-1){
				tran(b);
				printf("%s\n",b);
				memset(b,0,sizeof(b));
				break;
			}	// 等于字符串长度就是一个子串的结束 
		}
	}
	return 0;
}

 

你可能感兴趣的:(c,hdoj)