HDOJ Beat (DFS)

Beat

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1089    Accepted Submission(s): 652


Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem.
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
 

Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
 

Output
For each test case output the maximum number of problem zty can solved.


 

Sample Input
   
   
   
   
3 0 0 0 1 0 1 1 0 0 3 0 2 2 1 0 1 1 1 0 5 0 1 2 3 1 0 0 2 3 1 0 0 0 3 1 0 0 0 0 2 0 0 0 0 0
 

Sample Output
   
   
   
   
3 2 4
Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1.
 



主要是题意:
按题所说,T[i][j]表示在解决完第i道题后需要花T[i][j]的时间去解决第j道题,所以dfs的时候记录下一次要解决的题目

ac代码:
#include<stdio.h>  
#include<string.h>  
#include<iostream>  
#include<algorithm>  
#define MAXN 100
using namespace std; 
int map[MAXN][MAXN];
int v[MAXN];
int sum,n;
void dfs(int x,int num,int max)
{
	int i;
	for(i=0;i<n;i++)
	{
		if(v[i]==0&&map[x][i]>=max)
		{
			v[i]=1;
			dfs(i,num+1,map[x][i]);
			v[i]=0;
		}
	}
	if(sum<num)//取最大值
	sum=num;
}
int main()
{
	int i,j;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			scanf("%d",&map[i][j]);
		}
		memset(v,0,sizeof(v));
		v[0]=1;
		sum=0;
		dfs(0,1,0);
		printf("%d\n",sum);
	}
	return 0;
}


你可能感兴趣的:(HDOJ Beat (DFS))