HDOJ 2988 Dark roads(最小生成树--kruskul)

Dark roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 800    Accepted Submission(s): 330


Problem Description
Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?

 

Input
The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 2 31.
 

Output
For each test case print one line containing the maximum daily amount the government can save.
 

Sample Input
   
   
   
   
7 11 0 1 7 0 3 5 1 2 8 1 3 9 1 4 7 2 4 5 3 4 15 3 5 6 4 5 8 4 6 9 5 6 11 0 0
 

Sample Output
   
   
   
   
51 刚开始写了一发prime,MTLE,然后回来看了一下数据范围,20w,(汗,果断换用kruskul 题意就是怎么说呢,就是边权值总和减去最短路径的长度,然后得出的就是省下来的钱,即结果 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 200010
#define INF 0xfffffff
#define min(a,b) (a>b?b:a)
using namespace std;
int sum;
int pri[MAXN];
struct s
{
	int a;
	int b;
	int cost;
}dis[MAXN];
bool cmp(s A,s B)
{
	return A.cost<B.cost;
}
int find(int x)
{
	int r=x;
	while(r!=pri[r])
	r=pri[r];
	int i=x,j;
	while(i!=r)
	{
		j=pri[i];
		pri[i]=r;
		i=j;
	}
	return r;
}
void connect(int xx,int yy,int num)
{
	int nx=find(xx);
	int ny=find(yy);
	if(nx!=ny)
	{
		pri[nx]=pri[ny];
		sum+=num;
	}
}
int main()
{
	int i,d,e,m,n,s,c;
	while(scanf("%d%d",&n,&m)!=EOF,n||m)
	{
		for(i=0;i<n;i++)
		pri[i]=i;
		sum=0;
		s=0;
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&c,&d,&e);
			dis[i].a=c;
			dis[i].b=d;
			dis[i].cost=e;
			s+=e;//记录边权值总和
		}
		sort(dis,dis+m,cmp);
		for(i=0;i<m;i++)
		{
			connect(dis[i].a,dis[i].b,dis[i].cost);
		}
		printf("%d\n",s-sum);
    }
	return 0;
}


你可能感兴趣的:(HDOJ 2988 Dark roads(最小生成树--kruskul))