http://poj.org/problem?id=2063
Description
John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.
Assume the following bonds are available:
Value |
Annual interest |
4000 3000 |
400 250 |
With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200.
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.
Input
The first line contains a single positive integer N which is the number of test cases. The test cases follow.
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).
The following line contains a single number: the number d (1 <= d <= 10) of available bonds.
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.
Output
For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.
Sample Input
1
10000 4
2
4000 400
3000 250
Sample Output
14050
/**
poj 2063 完全背包问题
题意:去银行存钱。已知本金n,要存的年数year。本金存入可以划分为m种存储方式,每种方式对应的钱数、利息已知,上一年的利息计入下一年的本金,问怎么选择存储方式可以使得year年后获得钱最多。
解题思路:对于每一年的存储方式的选择都用一个背包来做,背包容量为上一年的本息之和。由于每种方式的钱数都是1000的倍数,所以都除以1000缩小要开数组的范围
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
int n,m,year,w[15],v[15],dp[50005];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d",&n,&year,&m);
for(int i=1;i<=m;i++)
{
scanf("%d%d",&w[i],&v[i]);
w[i]/=1000;//优化
}
int sum=0;
for(int i=0;i<year;i++)
{
memset(dp,0,sizeof(dp));
sum=n/1000;
for(int j=1;j<=m;j++)
{
for(int k=w[j];k<=sum;k++)
{
dp[k]=max(dp[k],dp[k-w[j]]+v[j]);
}
}
n+=dp[sum];//将今年赚到的作为下一年的初始资金
}
printf("%d\n",n);
}
return 0;
}