ACdream 1431 Sum vs Product

Description

      Peter has just learned mathematics. He learned how to add, and how to multiply. The fact that 2 + 2 = 2 × 2 has amazed him greatly. Now he wants find more such examples. Peters calls a collection of numbers beautiful if the product of the numbers in it is equal to their sum. 

      For example, the collections {2, 2}, {5}, {1, 2, 3} are beautiful, but {2, 3} is not. 

      Given n, Peter wants to find the number of beautiful collections with n numbers. Help him!

Input

      The first line of the input file contains n (2 ≤ n ≤ 500)

Output

      Output one number — the number of the beautiful collections with n numbers.

Sample Input

2
5

Sample Output

1
3

Hint

The collections in the last example are: {1, 1, 1, 2, 5}, {1, 1, 1, 3, 3} and {1, 1, 2, 2, 2}.

搜索

#include<cstdio>
#include<algorithm>
using namespace std;
int n;

int dfs(int limit,int x,int d,int sum)
{
	if (d==sum+n-x) return 1;
	if (d>sum+n-x||x>n) return 0;
	int ans=0;
	for (int i=1;i<=limit;i++) 
		ans+=dfs(i,x+1,d*i,sum+i);
	return ans;
}

int main()
{
	while (~scanf("%d",&n))
	{
		int ans=0;
		for (int i=1;i<=n;i++) 
			ans+=dfs(i,1,i,i);
		printf("%d\n",ans);
	}
}


你可能感兴趣的:(ACdream 1431 Sum vs Product)