UVA - 10881 - Piotr's Ants

UVA - 10881

Piotr's Ants
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

Problem D
Piotr's Ants
Time Limit: 2 seconds

"One thing is for certain: there is no stopping them;
the ants will soon be here. And I, for one, welcome our
new insect overlords."
Kent Brockman

Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.

Input
The first line of input gives the number of cases, NN test cases follow. Each one starts with a line containing 3 integers: L , T and n  (0 <=  n <= 10000)  . The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).

Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole beforeT seconds, print "Fell off" for that ant. Print an empty line after each test case.

Sample Input Sample Output
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
Case #1:
2 Turning
6 R
2 Turning
Fell off

Case #2:
3 L
6 R
10 R

Problemsetter: Igor Naverniouk
Alternate solutions: Frank Pok Man Chu and Yury Kholondyrev

Source

Root :: AOAPC I: Beginning Algorithm Contests -- Training Guide (Rujia Liu) :: Chapter 1. Algorithm Design :: General Problem Solving Techniques ::  Examples
Root :: Prominent Problemsetters ::  Igor Naverniouk (Abednego)







AC代码:

#include <cstdio> 
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn = 10005;

struct Ant {
	int id;		//输入顺序 
	int p;		//位置 
	int d;		//朝向。-1表示朝左;0表示正在碰撞;1表示朝右; 
	bool operator < (const Ant& a) const {		//用于sort函数 
		return p < a.p;
	}
}before[maxn], after[maxn];

const char dirName[][10] = {"L", "Turning", "R"}; 

int order[maxn]; //输入的第i只蚂蚁是终态中的左数第order[i]只蚂蚁 

int main() {
	int N, cas = 1;
	scanf("%d", &N);
	while(N--) {
		int L, T, n;
		printf("Case #%d:\n", cas++);
		scanf("%d %d %d", &L, &T, &n);
		for(int i = 0; i < n; i++) {
			int p, d;
			char c;
			scanf("%d %c", &p, &c);
			d = (c == 'L' ? -1: 1);
			before[i] = (Ant){i, p, d};			//初始状态 
			after[i] = (Ant){0, p+T*d, d};		//末状态 
		}
		
		//计算order数组
		sort(before, before+n);
		for(int i = 0; i < n; i++) 
			order[before[i].id] = i;
			
		//计算终态
		sort(after, after+n);
		for(int i = 0; i < n-1; i++) 
			if(after[i].p == after[i+1].p) after[i].d = after[i+1].d = 0;
		
		//输出结果 
		for(int i = 0; i < n; i++) {
			int a = order[i];		//a表示实际顺序 
			if(after[a].p < 0 || after[a].p > L) printf("Fell off\n");
			else printf("%d %s\n", after[a].p, dirName[after[a].d+1]); 
		}
		printf("\n");
	} 
	return 0;
} 







你可能感兴趣的:(ACM,uva)