HDOJ 1091 A+B for Input-Output Practice (IV)

Problem Description
Your task is to Calculate the sum of some integers.
 

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

Sample Input
   
   
   
   
4 1 2 3 4 5 1 2 3 4 5 0
 

Sample Output
   
   
   
   
10 15
 
#include <iostream>
#include <cstring>
using namespace std;
int main(int argc, const char * argv[]) {
    int n,sum,temp;
    while(scanf("%d",&n)==1&&n)
    {
        sum=0;
        for(int i=1;i<=n;i++)
        {
            cin>>temp;
            sum+=temp;
        }
        cout<<sum<<endl;
    }
    return 0;
}


你可能感兴趣的:(HDOJ 1091 A+B for Input-Output Practice (IV))