ACM ICPC 2013-2014 B. The battle near the swamp(水~)

Description
n块区域,每块区域有k个目标,有n箱炸弹,每箱ai个,第i箱炸第i块区域,一个炸弹炸毁一个目标,问最后剩余的炸弹数和目标数
Input
第一行两个整数n和k分别表示区域数和每块区域的目标数,第二行n个整数分别表示每箱炸弹的数量
Output
输出最后剩余的炸弹数和目标数
Sample Input
4 5
2 7 5 0
Sample Output
2 8
Solution
水题,炸弹数比目标数多就累加剩余炸弹数,目标数比炸弹数多就累加剩余目标数
Code

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k))
    {
        int boom=0,tar=0;
        while(n--)
        {
            int x;
            scanf("%d",&x);
            if(x<k) 
                tar+=(k-x);
            else
                boom+=(x-k);
        }
        printf("%d %d\n",boom,tar);
    }
    return 0;
}

你可能感兴趣的:(ACM ICPC 2013-2014 B. The battle near the swamp(水~))