POJ 3356 AGTC

AGTC
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12261   Accepted: 4602

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

Source

Manila 2006

点击打开题目链接

由字符串 A 通过下列三种操作
 1、插入一个字符;
   2、删除一个字符;
 3、改变一个字符
变换到字符串 B 所需要的最少操作次数(感觉和最长公共子序列有点相似)

状态转移方程:
有三种情况可以导致我们上面设计的状态会发生转移。我们现在来看A[i] 和 B[j] ,
①、我们可以在 B[j]后面插入一个核苷酸(即一个字符)ch,ch==A[i],这样做的话,
至少需要 dp[i - 1][j] + 1步操作,即 dp[i][j] = dp[i - 1][j] + 1。
②、我们可以删除 B[j],这样的话,B[1...j] 变为A[1...i] 需要 dp[i][j - 1]步,
即 dp[i][j] = dp[i][j - 1] + 1。
③、我们也可以考虑修改 B[j],使它变为A[i],但是如果 B[j]本来就等于 A[i] 的话,
那修改其实相当于用了 0 步,如果 B[j] != A[i] 的话,那修改相当于用了 1 步。
所以 dp[i][j] = dp[i - 1][j - 1] + (A[i] == B[j] ? 0 : 1)。

决策:
决策就很简单了,从上面三种状态转移中选择一个最小值就可以了。

处理边界:
处理好边界非常重要,这里需要注意的是对dp[0][0....m],dp[0.....n][0]的初始化,
可以这样看,dp[0][i],就是说A[1...n]是一个空串,而B[1...m]是个长度为i的串,
很显然B串变为A串就是删除i个核苷酸。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

const int maxn = 1000 + 5;
char A[maxn], B[maxn];
int dp[maxn][maxn];
int len1, len2;

void init()
{
	memset(dp, 0, sizeof(dp));
	int Len = max(len1, len2);
	for (int i = 0; i <= Len; i++)	//处理边界 
		dp[i][0] = dp[0][i] = i;
}

int solve()
{
	for (int i = 0; i < len1; i++)
	{
		for (int j = 0; j < len2; j++)	//状态转移,选三种状态中最小的 
		{
			if (A[i] == B[j])
				dp[i + 1][j + 1] = min(dp[i][j], min(dp[i + 1][j] + 1, dp[i][j + 1] + 1));
			else 
				dp[i + 1][j + 1] = min(dp[i][j] + 1, min(dp[i + 1][j] + 1, dp[i][j + 1] + 1));
		}
	}
	return dp[len1][len2];
}

int main()
{
	
	while (~scanf("%d%s", &len1, A))
	{
		scanf("%d%s", &len2, B);
		init();
		printf("%d\n", solve());
	}
	
    return 0;
}


你可能感兴趣的:(dp,ACM)