BestCoder Round #80B

Segment

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1080    Accepted Submission(s): 396



提示:
可以用二分乘法;
Problem Description
     Silen August does not like to talk with others.She like to find some interesting problems.

     Today she finds an interesting problem.She finds a segment x+y=q .The segment intersect the axis and produce a delta.She links some line between (0,0) and the node on the segment whose coordinate are integers.

     Please calculate how many nodes are in the delta and not on the segments,output answer mod P.
 

Input
     First line has a number,T,means testcase number.

     Then,each line has two integers q,P.

    q is a prime number,and 2q1018,1P1018,1T10.
 

Output
     Output 1 number to each testcase,answer mod P.
 

Sample Input
   
   
   
   
1 2 107
 

Sample Output
   
   
   
   
0
 

Source
BestCoder Round #80
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5669  5668  5667  5664  5663


#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <cstdio>
#include <vector>
#define LL long long
using namespace std;
int n;
void solve(LL a,LL b,LL p)
{
    LL ans=0;
    while(b)
    {
        if(b&1)
        (ans+=a)%=p;
        (a+=a)%=p;
        b>>=1;
    }
    printf("%I64d\n",ans);
}
int main()
{
    LL a,b;
    LL tmp1,tmp2;
    int t;
    cin>>t;
    while(t--)
    {
        cin>>a>>b;
        tmp1=a-1,tmp2=a-2;
        if(tmp1%2)
            solve(tmp1,tmp2/2,b);
        else
            solve(tmp2,tmp1/2,b);
    }
    return 0;
}

 

你可能感兴趣的:(BestCoder Round #80B)