http://poj.org/problem?id=1742
Description
People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
/**
poj 1742 多重背包可行性问题
多重背包如果用三层循环会超时,用一个数组t表示i物品被用了多少次
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int n,m,ans;
int v[105],c[105],t[100001];
bool p[100001];
int main()
{
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0)
break;
for(int i=0;i<n;i++)
scanf("%d",&v[i]);
for(int i=0;i<n;i++)
scanf("%d",&c[i]);
memset(p,0,sizeof(p));
ans=0,p[0]=1;
for(int i=0;i<n;i++)
{
memset(t,0,sizeof(t));
for(int j=v[i];j<=m;j++)
{
if(!p[j]&&p[j-v[i]]&&t[j-v[i]]<c[i])
{
t[j]=t[j-v[i]]+1;
p[j]=1;
ans++;
}
}
}
printf("%d\n",ans);
}
return 0;
}