Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)
…
an, a1, a2, …, an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
先求出m==0时的逆序数,因为题目中给出的数字序列是从0~n-1,所以每次输入a[i]时,可以询问a[i]~n-1区间内是否有数字,询问完毕后将a[i]插入线段树的a[i]位置上,将此位置的值设为1,代表这儿已经有了a[i]这个数字。将来再输入a[j]时,若 a[j]小于a[i],那么询问a[j]~n-1时一定会遇到a[i],a[i]就是a[j]的一个逆序数
有个结论,设逆序数为sum,x[0]后面比它小的一定是x[0]个。那么移到末尾后,比x[0]大的数的后面比它小的数统统加一,也就是加(n - a[0] - 1),然后它放到末尾了,他原来的后面比它小的数变为0,也就是sum = sum + (n - a[0] - 1) - a[0]
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
#include <queue>
#include <set>
#define MAXN 222222
#define mod 4000010
using namespace std;
const int maxn=222222;
int sum[maxn<<2];
void PushUp(int rt)
{
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
sum[rt]=0;
if(r==l)
{
return;
}
int m=(l+r)>>1;
build(l,m,rt<<1);
build(m+1,r,rt<<1|1);
}
void update(int p,int l,int r,int rt)
{
if(l==r)
{
sum[rt]++;
return;
}
int m=(l+r)>>1;
if(p<=m)
update(p,l,m,rt<<1);
else
update(p,m+1,r,rt<<1|1);
PushUp(rt);
}
int query(int L,int R,int l,int r,int rt)
{
if(L<=l&&r<=R)
return sum[rt];
int m=(l+r)>>1;
int ret=0;
if(L<=m)
ret+=query(L,R,l,m,rt<<1);
if(R>m)
ret+=query(L,R,m+1,r,rt<<1|1);
return ret;
}
int main()
{
int a[5010];
int n,sum,ret;
while(~scanf("%d",&n))
{
build(0,n-1,1);
sum=0;
for(int i=0;i<n;++i)
{
scanf("%d",&a[i]);
sum+=query(a[i],n-1,0,n-1,1);
update(a[i],0,n-1,1);
}
ret=sum;
for(int i=0;i<n;++i)
{
sum+=n-a[i]-1-a[i];
ret=min(sum,ret);
}
printf("%d\n",ret);
}
return 0;
}