Sort it
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2847 Accepted Submission(s): 2056
Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
Output
For each case, output the minimum times need to sort it in ascending order on a single line.
Sample Input
Sample Output
Author
WhereIsHeroFrom
冒牌排序
中间调换两个数字的时候我没有用中间变量
对于整形实型和字符型来说不需要中间变量就可以调换顺序
#include<stdio.h>
#include<string.h>
int T,i,j,k;
int num[10005];
int main()
{
while(scanf("%d",&T) != EOF)
{
k = 0;
for(i =0 ;i < T;i++)
{
scanf("%d",&num[i]);
}
for(j = 0; j< T ;j++)
{
for(i =0 ;i < T -j -1;i++)
{
if(num[i] > num[i+1])
{
num[i] = num[i] + num[i+1];//这里看起来可能会有点晕
num[i+1] = num[i] - num[i+1];
num[i] = num[i] - num[i+1];
k++;
}
}
}
printf("%d\n",k);
}
return 0;
}