HDOJ 4763 Theme Section

扩展kmp找前缀长。。。


Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 968    Accepted Submission(s): 512


Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
   
   
   
   
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output
   
   
   
   
0 0 1 1 2
 

Source
2013 ACM/ICPC Asia Regional Changchun Online
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=1100000;

char P[maxn];
int next[maxn];

void pre_exkmp(char P[])
{
    int m=strlen(P);
    next[0]=m;
    int j=0,k=1;
    while(j+1<m&&P[j]==P[j+1]) j++;
    next[1]=j;
    for(int i=2;i<m;i++)
    {
        int p=next[k]+k-1;
        int L=next[i-k];
        if(i+L<p+1) next[i]=L;
        else
        {
            j=max(0,p-i+1);
            while(i+j<m&&P[i+j]==P[j]) j++;
            next[i]=j; k=i;
        }
    }
}

int main()
{
    int T_T;
    scanf("%d",&T_T);
while(T_T--)
{
    scanf("%s",P);
    int n=strlen(P);
    pre_exkmp(P);
    int ans=0;
    for(int i=1;i+ans<n;i++)
    {
        int Len=min(next[i],i);
        while(n-Len<i+Len&&Len>ans) Len--;
        if(Len<=ans) continue;
        for(int j=n-Len;j<n-ans;j++)
        {
            if(next[j]>=n-j)
            {
                ans=max(ans,n-j);break;
            }
        }
    }
    printf("%d\n",ans);
}
    return 0;
}



你可能感兴趣的:(HDOJ 4763 Theme Section)