HDOJ 1089 A+B for Input-Output Practice (I)

A+B for Input-Output Practice (I)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 112794    Accepted Submission(s): 61461


Problem Description
Your task is to Calculate a + b.
Too easy?! Of course! I specially designed the problem for acm beginners.  
You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim. 
 

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line. 
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

Sample Input
   
   
   
   
1 5 10 20
 

Sample Output
   
   
   
   
6 30
 

Author
lcy
 

Recommend
//
//  main.cpp
//  A+B for Input-Output Practice (I)
//
//  Created by 张嘉韬 on 16/1/28.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
using namespace std;
int main(int argc, const char * argv[]) {
    int a,b;
    while(scanf("%d%d",&a,&b)==2)
    {
        cout<<a+b<<endl;
    }
    return 0;
}
总结:由该题可见,当输入数据的组数未定的时候可以用while再加上合适的条件,输出部分在最后多输出endl并没有问题


你可能感兴趣的:(HDOJ 1089 A+B for Input-Output Practice (I))