POJ 3187- Backward Digit Sums(DFS+全排列)

E - Backward Digit Sums
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 3187
Appoint description:  System Crawler  (2016-05-02)

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4 
 4   3   6 
 7   9 
 16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

题意:
给你n个数,然后要最小的字典序,像图上一样加到最后一个数是m是什么序列。

AC代码:

/*
这题题意是找到一个字典序最小,而且经过图上的
不断向下加数,求出的答案相同就是了。而dfs是
按照从大到小的,所以字典序肯定是最优的。
这题可以用分治法+dfs暴力答案,因为最大才是十。
*/


#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
#include<ctime>
#include<cstdlib>
#include<queue>
#include<vector>
using namespace std;
const int T=500;
#define inf 0x3f3f3f3fL
typedef long long ll;

int a[15],b[15],n,m;
bool vis[15];

bool slove()
{
	int c1=n/2,c2=0,t[15];
	for(int i=0;i<n;++i){
		if(!vis[i]){
			b[c2++]=i+1;
		}
	}
	do
	{
		for(int i=0;i<n;++i){
			if(i<c1){
			  t[i] = a[i];
			}
			else{
			  t[i] = b[i-c1];
			}
		}
		for(int i=n-2;i>=0;--i){//三角形
			for(int j=0;j<=i;++j){
				t[j] += t[j+1];
			}
		}
		if(t[0]==m){
			for(int i=0;i<n;++i){
				if(i<c1){
					printf("%d ",a[i]);
				}
				else {
					printf("%d ",b[i-c1]);
				}
			}
			printf("\n");
			return true;
		}
	}while(next_permutation(b,b+c2));
	return false;
}

bool flag ;

void dfs(int c)
{
	if(flag)return;
	if(c==n/2){
		if(slove()){
			flag = true;
		}
		return;
	}
	for(int i=0;i<n;++i){
		if(!vis[i]){
			vis[i] = true;
			a[c] = i+1;
			dfs(c+1);
			vis[i] = false;
		}
	}

}

int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif

	int i,j,k;
	while(~scanf("%d%d",&n,&m))
	{
		memset(vis,false,sizeof(vis));
		flag = false;
		dfs(0);
	}
	return 0;
}


你可能感兴趣的:(poj,DFS)