poj 3187 Backward Digit Sums

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.


题意:给出行数n与和sum , 要求求出满足sum和底序列;每一列的非顶点都按照杨辉三角相加得来; 

题解:用stl中的全排列函数,将每一次的情况模拟出来, 然后看杨辉三角的顶点是否等于sum ,直接break。就是最小序列;

PS:全排列函数是直接进行排列,不保留当前序列;即若1 2 3 4 , 则使用后while就是1 3 2 4 , 故用do while ;

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
int n , sum , dp[20][20] ;
int main()
{
    while(cin>>n>>sum)
    {
        memset(dp,0,sizeof(dp));
        int input[10] = {1,2,3,4,5,6,7,8,9,10};
        while(next_permutation(input , input+n))
        {
            for(int i = 0 ; i < n ;i++)
                dp[0][i] = input[i];   //*dp[i][j] 代表从下往上第i行第j个数字;
            for(int i = 1 ; i<n ;i++)  //*枚举第二行向上搜索
            {
                for(int j = 0 ; j < n-i;j++)
                {
                    dp[i][j] = dp[i-1][j] + dp[i-1][j+1];
                }
            }
            if(dp[n-1][0]==sum)
            {
                break;
            }

        }
                printf("%d",dp[0][0]);
                for(int i = 1 ; i<n ; i++)
                {
                    printf(" %d",dp[0][i]);
                }
                printf("\n");
    }
    return 0 ;
}


你可能感兴趣的:(poj 3187 Backward Digit Sums)