Hduoj2071 【水题】

/*Max Num
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14216    Accepted Submission(s): 8965


Problem Description
There are some students in a class, Can you help teacher find the highest student .
 

Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
 

Output
For each case output the highest height, the height to two decimal plases;
 

Sample Input
2
3 170.00 165.00 180.00
4 165.00 182.00 172.00 160.00
 

Sample Output
180.00
182.00
 

Author
Lily
 

Source
浙江工业大学网络选拔赛 
 
*/
#include<stdio.h>
int main()
{
	int i, n, m;
	double sum, j, k;
	scanf("%d", &n);
	while(n--)
	{
		scanf("%d", &m);
		sum = 0;
		for(i = 0; i < m; i++)
		{
			scanf("%lf", &j);
			if(j > sum)
			sum = j;
		}
		printf("%.2lf\n", sum); 
	}
	return 0;
}

你可能感兴趣的:(c)