HDOJ 5317 RGCDQ 水


预处理出每个数有多少个不同的因数,因数最多不超过7

RGCDQ

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 641    Accepted Submission(s): 304


Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j))   (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line. 
See the sample for more details.
 

Sample Input
   
   
   
   
2 2 3 3 5
 

Sample Output
   
   
   
   
1 1
 

Source
2015 Multi-University Training Contest 3
 


/* ***********************************************
Author        :CKboss
Created Time  :2015年07月28日 星期二 21时27分27秒
File Name     :HDOJ5317.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int maxn=1000100;

int kut[maxn];
int num[10][maxn];
int ggd[10][10];

void init()
{
	for(int i=2;i<maxn;i++)
	{
		if(kut[i]==0)
		{
			for(int j=i;j<maxn;j+=i)
			{
				kut[j]++;
			}
		}
	}

	for(int i=2;i<maxn;i++)
	{
		num[kut[i]][i]++;
	}

	for(int j=2;j<maxn;j++)
	{
		for(int i=1;i<=7;i++)
		{
			num[i][j]=num[i][j]+num[i][j-1];
		}
	}

	for(int i=1;i<=10;i++)
	{
		for(int j=1;j<=10;j++)
		{
			if(ggd[i][j]==0)
			{
				ggd[i][j]=ggd[j][i]=__gcd(i,j);
			}
		}
	}
}

int L,R;
int nb[10];

int solve()
{
	if(L==R)
	{
		return kut[L];
	}

	for(int i=1;i<=7;i++) 
		nb[i]=num[i][R]-num[i][L-1];

	int ans=0;
	for(int j=7;j>=1;j--)
	{
		if(nb[j]==0) continue;
		for(int i=7;i>=1;i--)
		{
			if(nb[i]==0) continue;
			if(j==i) 
			{
				if(nb[j]>1) ans=max(ans,j);
			}
			else ans=max(ans,ggd[i][j]);
		}
	}

	return ans;
}

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	init();

	int T_T;
	scanf("%d",&T_T);
	while(T_T--)
	{
		scanf("%d%d",&L,&R);
		int ans=solve();
		printf("%d\n",ans);
	}
    
    return 0;
}



你可能感兴趣的:(HDOJ 5317 RGCDQ 水)