Hduoj2069 【母函数】【暴力】【水题】

/*Coin Change
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13903    Accepted Submission(s): 4652


Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
11
26
 

Sample Output
4
13
 

Author
Lily
 

Source
浙江工业大学网络选拔赛 
*/
#include<stdio.h>
int main()
{
	int i, j, k, a, b, c, d, e, n;
	while(scanf("%d", &n) != EOF)
	{
		if(n == 0)
		{
			printf("1\n");
			continue; 
		}
		k = 0;
		for(a = 0; 50 * a <= n; a++)
		for(b = 0; 25 * b <= n; b++)
		for(c = 0; 10 * c <= n; c++)
		for(d = 0; 5 * d <= n; d++)
		for(e = 0; e  <= n; e++)
		if(a*50 + b*25 + c*10 + d*5 + e == n && a+b+c+d+e <= 100)
		k++;
		printf("%d\n", k);
	}
	return 0;
} 
//此题可以用母函数去做,不过和暴力解法性质一样。

你可能感兴趣的:(c)