[kuangbin带你飞]专题一 简单搜索 D - Fliptile

Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6627   Accepted: 2518

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0


分析:1.枚举,枚举只需要对第一行进行。

   2.翻转的概念,翻转偶数次等于没翻。[能够免去进行翻转这个过程,与数组][一个优化]

code:

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <cstring>
#include <queue>
#define INF 0x7FFFFFFF

using namespace std;

int n,m;
int arr[20][20],flip[20][20],ans[20][20];
const int dir[][2]={
    0,0, 0,1, 0,-1, -1,0, 1,0
};

int get(int x,int y)//(x,y)的颜色
{
    int c= arr[x][y];
    for(int i=0;i<5;i++)
    {
        int a=x+dir[i][0];
        int b=y+dir[i][1];
        if(a>=0&&a<n&&b>=0&&b<m)
        {
            c+=flip[a][b];
        }
    }
    return c&1;
}

int calc()
{
    for(int i=1;i<n;i++){
        for(int j=0;j<m;j++){
            if(get(i-1,j)) flip[i][j]=1;
        }
    }
    for(int i=0;i<m;i++){ //只要关注最后一行是不是都为0
        if(get(n-1,i)) return 0;
    }
    int cnt=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
            cnt+=flip[i][j];
    return cnt;
}

void solve()
{
    int cnt=INF;
    for(int i=0;i<(1<<m);i++)
    {
        memset(flip,0,sizeof flip);
        for(int j=0;j<m;j++)
        {
            flip[0][m-j-1]=(i>>j)&1;
        }
        int num=calc();
        if(num<cnt&&num!=0)
        {
            cnt=num;
            memcpy(ans,flip,sizeof flip);
        }
    }
    if(cnt==INF) cout<<"IMPOSSIBLE"<<endl;
    else
    {
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                cout<<ans[i][j];
                j==m-1? cout<<endl:cout<<' ';
            }
    }
}

int main(void)
{
    while(cin>>n>>m)
    {
        memset(arr,0,sizeof arr);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                cin>>arr[i][j];
        
        solve();
    }
}

你可能感兴趣的:([kuangbin带你飞]专题一 简单搜索 D - Fliptile)