HDOJ 1212 Big Number


Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4048    Accepted Submission(s): 2795


Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
   
   
   
   
2 3 12 7 152455856554521 3250
 

Sample Output
   
   
   
   
2 5 1521
 

Author
Ignatius.L
 

Source
杭电ACM省赛集训队选拔赛之热身赛
 

import java.util.Scanner;
import java.math.*;

public class Main
{
  public static void main(String args[])
  {
    Scanner cin=new Scanner(System.in);
    BigInteger a,b;
    while(cin.hasNext())
    {
      a=cin.nextBigInteger();
      b=cin.nextBigInteger();
      System.out.println(a.mod(b));
    }
  }
}




你可能感兴趣的:(HDOJ 1212 Big Number)