Hduoj1051 【贪心】【水题】

/*Problem D 
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 8
Font: Times New Roman | Verdana | Georgia 
Font Size: ← →
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l'
 and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks
 whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes
  since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test 
case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in 
the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 
10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited
 by one or more spaces.

Output
The output should contain the minimum setup time in minutes, one per line.

Sample Input
3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output
2
1
3
*/
#include<stdio.h>
#include<stdlib.h>
#include<string.h> 
struct p
{
	int x, y;
}a[10010];
int cmp(const void *a, const void*b)
{
	struct p *c = (struct p *)a;
	struct p *d = (struct p *)b;
	if( c->x != d->x )
	return c->x - d->x;
	else
	return c->y - d->y;
}
int  mark[10010];
int main()
{
	int i, j , k, m , n, sum, l, w;
	scanf("%d", &n);
	while(n--)
	{
		sum = 0;
		scanf("%d", &m);
		for(i = 0; i < m; i++)
		scanf("%d%d", &a[i].x, &a[i].y);
		memset(mark, 0, sizeof(mark));
		qsort(a, m, sizeof(a[0]), cmp);
		for(i = 0; i < m; i++)
		{
			if(!mark[i])
			{
				k = i;
				sum++;
			}
			else
			continue;
			l = a[i].x;
			w = a[i].y;
			for(j = k+1; j < m; j++)
			{
				if(a[j].x >= l && a[j].y >= w && !mark[j])
				{
					mark[j] = 1;
					l = a[j].x;
					w = a[j].y;
				}
			}
		}
		printf("%d\n", sum);
	}
	return 0;
}

你可能感兴趣的:(c)