hdu 3835 简单概率dp

R(N)

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 3   Accepted Submission(s) : 1
Problem Description
We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example, 
10=(-3)^2+1^2.
We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).
 

Input
No more than 100 test cases. Each case contains only one integer N(N<=10^9).
 

Output
For each N, print R(N) in one line.
 

Sample Input
   
   
   
   
2 6 10 25 65
 

Sample Output
   
   
   
   
4 0 8 12 16
Hint
For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(!n)
        {
            printf("1\n");
            continue;
        }
        int i,j,ans=0,ave=(int)sqrt(double(n/2.0));
        for(i=ave; i>=0; i--)
        {
             j=(int)sqrt(1.0*(n-i*i));
                if(i*i+j*j==n)
                {
                    if(i==0||j==0||i==j) ans+=4;
                    else ans+=8;
                }
        }
        printf("%d\n",ans);
    }
    return  0;
}
/*
2
6
10
25
65
*/


Source
2011 Multi-University Training Contest 1 - Host by HNU
 

你可能感兴趣的:(hdu 3835 简单概率dp)