HDU 1058 Humble Numbers dp

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21609    Accepted Submission(s): 9439


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
   
   
   
   
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
   
   
   
   
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000. 题意: 给一个序号数,让你求出在这个序号对应的数; 数的构成规则是只能由2,3,5,7这几个数构成。。不能包含其他素数; a[i]=Min(2*a[k],3*a[j],5*a[x],7*a[y]); 这样我们可以一次都不漏的把所有的丑数按照从小到大的顺序推出 (意思是从小到大让数值都分别乘2,3,5,7得到新数) 。。。。。 dp就是直接利用以前的数据,才减少时间的浪费。。
#include<bits/stdc++.h>
using namespace std;
int a[100000];
int Min(int a,int b,int c,int d)
{
    int z[10]={a,b,c,d};
    sort(z,z+4);
    return z[0];
}
int main()
{
    int k=1,j=1,x=1,y=1,n;
    a[1]=1;
    for(int i=2;i<=5843;i++)
    {
        a[i]=Min(2*a[k],3*a[j],5*a[x],7*a[y]);
        if(a[i]==2*a[k])k++;
        if(a[i]==3*a[j])j++;
        if(a[i]==5*a[x])x++;
        if(a[i]==7*a[y])y++;
    }
    while(~scanf("%d",&n))
    {
        if(!n)break;
        if(n%10==1&&n%100!=11)
         printf("The %dst humble number is %d.\n",n,a[n]);
         else if(n%10==2&&n%100!=12)
        printf("The %dnd humble number is %d.\n",n,a[n]);
          else if(n%10==3&&n%100!=13)
              printf("The %drd humble number is %d.\n",n,a[n]);
          else
              printf("The %dth humble number is %d.\n",n,a[n]);

    }
    return 0;
}


你可能感兴趣的:(HDU 1058 Humble Numbers dp)