Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
思路:使用c++标准模板库中的map,键是气球的颜色,值是气球数量。每次插入先检查是否有该颜色的气球存在,如果存在则数量加一,如果不存在则插入该颜色。最后遍历找出最大值。
注意:map的使用。
代码:
<span style="font-size:18px;">#include <iostream>
#include <stdio.h>
#include <string.h>
#include <map>
using namespace std;
int main()
{
map<string,int>m;
char c[16];
int n,i,maxN;
while(scanf("%d",&n)&&n!=0){
m.clear();
map<string,int>::iterator iter;
for(i=0;i<n;i++){
scanf("%s",c);
iter=m.find(c);
if(iter==m.end()){
m.insert(map<string,int>::value_type(c,1));
}
else{
iter->second+=1;
}
}
maxN=0;
for(iter=m.begin();iter!=m.end();iter++){
if(iter->second>maxN){
string s=iter->first;
strcpy(c,s.c_str());
maxN=iter->second;
}
}
printf("%s\n",c);
}
return 0;
}
</span>