1027. Colors in Mars (20)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output

#123456


IDEA

1.10进制到13进制的转换

2.每个值有两位,如果只求出以为,其高位(左边)需要补零


CODE

#include<iostream>
using namespace std;
void toRadix13(char a[],int n){
	int i=0,p;
	while(n){
		p=n%13;
		if(p>=0&&p<=9){
			a[i++]=p+'0';
		}else if(p==10){
			a[i++]='A';
		}else if(p==11){
			a[i++]='B';
		}else if(p==12){
			a[i++]='C';
		}	
		n/=13;
	}
}
int main(){
	int r,g,b;
	cin>>r>>g>>b;
	char r_num[2]={'0','0'},g_num[2]={'0','0'},b_num[2]={'0','0'};
	toRadix13(r_num,r);
	toRadix13(g_num,g);
	toRadix13(b_num,b);
	cout<<"#"<<r_num[1]<<r_num[0]<<g_num[1]<<g_num[0]<<b_num[1]<<b_num[0];
	return 0;
}

你可能感兴趣的:(进制转换,pat)