hdu3530 Subsequence

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2136    Accepted Submission(s): 708


Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

Output
For each test case, print the length of the subsequence on a single line.
 

Sample Input
   
   
   
   
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

Sample Output
   
   
   
   
5 4
 

Source
2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU
 

Recommend
zhengfeng



单调队列。

维护最大值和最小值,如果发现最大值和最小值的差大于k,那么就移动下标最靠前的队列。

注意如下数据:

5 2 4

2 1 5 2 2

应该用一个last标记上一个移动的位置,然后答案就是max{i-last},之前没有这个标记wa了一次。

#include <stdio.h>
#include <queue>
#include <algorithm>
using namespace std;

int a[100005];
deque <int> q1;
deque <int> q2;

int main()
{
    int i,j,n,x,y,ans,last;
    while(scanf("%d%d%d",&n,&x,&y)!=EOF)
    {
        for (i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        ans=0;
        last=-1;
        while(!q1.empty()) q1.pop_front();
        while(!q2.empty()) q2.pop_front();
        for (i=0;i<n;i++)
        {
            while(!q1.empty() && a[i]>a[q1.back()]) q1.pop_back();
            while(!q2.empty() && a[i]<a[q2.back()]) q2.pop_back();
            q1.push_back(i);
            q2.push_back(i);
            while(!q1.empty() && !q2.empty() && a[q1.front()]-a[q2.front()]>y)
            {
                if (q1.front()>q2.front())
                {
                    last=q2.front();
                    q2.pop_front();
                }
                else if (q1.front()<q2.front())
                {
                    last=q1.front();
                    q1.pop_front();
                }
                else
                {
                    last=q1.front();
                    q1.pop_front();
                    q2.pop_front();
                }
            }
            if (!q1.empty() && !q2.empty() && a[q1.front()]-a[q2.front()]>=x)
            {
                ans=max(ans,i-last);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(ini,input,each,output,2010,Training)