Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 208994 Accepted Submission(s): 48944
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
用一个ThisSum存放当前子列和,MaxSum为最终的最大子列和,当累加后ThisSum < 0时,ThisSum重置为0,因为当前ThisSum为负数的时候显然对后面的
累加和不会做正的贡献,重新计算新的子列和
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int a[100000 + 10];
int main()
{
int T, N;
scanf("%d", &T);
for (int t = 1; t <= T; t++) {
scanf("%d", &N);
for (int i = 1; i <= N; i++) {
scanf("%d", &a[i]);
}
//s用来存储临时子列起点,fs是最终子列的起点
//e是最终子列的终点
int ThisSum, MaxSum, s, e, fs;
bool pfu;
pfu = true;
ThisSum = 0;
MaxSum = a[1];
fs = e = 1;
for (int i = 1; i <= N; i++) {
//pfu为true说明ThisSum刚刚被置为0,重新记录起点
if (pfu) s = i;
pfu = false;
ThisSum += a[i];
if (ThisSum > MaxSum) {
MaxSum = ThisSum;
fs = s;
e = i;
}
if (ThisSum < 0) {
pfu = true;
ThisSum = 0;
}
}
printf("Case %d:\n", t);
printf("%d %d %d\n", MaxSum, fs, e);
if (t != T) puts("");
}
return 0;
}