hdu1564 Play a game

Play a game

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1141 Accepted Submission(s): 934


Problem Description
New Year is Coming!
ailyanlu is very happy today! and he is playing a chessboard game with 8600.
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can't make a move will lose the game. If both play perfectly, who will win the game?

Input
The input is a sequence of positive integers each in a separate line.
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output
Output the winner ("8600" or "ailyanlu") for each input line except the last zero.
No other characters should be inserted in the output.

Sample Input
   
   
   
   
2 0

Sample Output
   
   
   
   
8600

Author
ailyanlu
根据奇偶找归律!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n){
        if(n&1)printf("ailyanlu\n");
        else printf("8600\n");
    }
    return 0;
}


你可能感兴趣的:(hdu1564 Play a game)