HDU3172 Virtual Friends

E - 并查集
Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 3172

Description

These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.        

Your task is to observe the interactions on such a website and keep track of the size of each person's network.        

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.      
              

Input

Input file contains multiple test cases.        
The first line of each case indicates the number of test friendship nest.       
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).       
              

Output

Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.      
              

Sample Input

      
      
      
      
1 3 Fred Barney Barney Betty Betty Wilma
              

Sample Output

      
      
      
      
2 3 4
        
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
const int maxn=100000+5;
int par[maxn],num[maxn];//用来记录在同一条树上同类型的个数
char a[25],b[25];
map<string,int>s;
int T,F,ncount;
void init() {
    for(int i=0; i<maxn; i++) {
        par[i]=i;
        num[i]=1;
    }
    s.clear();
    ncount=1;
}
int find(int x) {
    return par[x]==x?x:par[x]=find(par[x]);
}
void unite(int x,int y) {
    x=find(x);
    y=find(y);
    if(x==y)return;
    par[x]=y;
    num[y]+=num[x];
}
int main() {
    while(~scanf("%d",&T)) {
        while(T--) {
            init();
            scanf("%d",&F);
            while(F--) {
                scanf("%s%s",&a,&b);
                /**************通过map可以将字符串以及一些特殊的结构与数字关联,起到哈希函数的作用(更加简洁)**********************/
                if(s[a]==0)s[a]=ncount++;
                if(s[b]==0)s[b]=ncount++;
                /************************************/
                unite(s[a],s[b]);
                printf("%d\n",num[find(s[a])]);
            }
        }
    }
    return 0;
}

你可能感兴趣的:(HDU3172 Virtual Friends)