hdu2795 Billboard 线段树单点更新区间最值

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17336    Accepted Submission(s): 7318


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
   
   
   
   
3 5 5 2 4 3 3 3
 

Sample Output
   
   
   
   
1 2 1 3 -1


对于线段树的规模,N取min(h, n),即如果h大, n小的话,取n,原因是h中有一部分是用不到的

如果n大,h小的话,取h,原因是,n放不下,而板子只有那么大


每个sum[rt]存区间[l, r]中的可能的单行最大容量,l == r时l or r即为板子的这一行的编号,只要在递归的时候左子树优先,就可以保证板子上面有位置先放上面的,然后再放下面

遇到能放的位置,从下到上更新区间区间内单行最大容量


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1

using namespace std;

const int maxn = 222222;
int sum[maxn << 2], ans[maxn], len;
int h, w, n;

void PushUP(int rt) {
	sum[rt] = max(sum[rt << 1], sum[rt << 1 | 1]);
}

void build(int l, int r, int rt) {
	if (l == r) {
		//初始最大长度都是w
		sum[rt] = w;
		return;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUP(rt);
}

void update(int p, int l, int r, int rt) {
	if (l == r) {
		if (sum[rt] >= p) {
			sum[rt] -= p;
			ans[len++] = l; //记录当前放得行编号
		}
		return;
	}
	int m = (l + r) >> 1;

	//注意优先更新左子树,因为要尽可能往上放
	if (sum[rt << 1] >= p) {
		update(p, lson);
	}
	else if (sum[rt << 1 | 1] >= p) {
		update(p, rson);
	}
	PushUP(rt);
}

int main()
{
	while (~scanf("%d%d%d", &h, &w, &n)) {
		memset(ans, -1, sizeof(ans));
		int N = min(h, n);
		build(1, N, 1);
		len = 0;
		for (int i = 0; i < n; i++) {
			int tem;
			scanf("%d", &tem);
			//sum[1]存的是所有的行中可能的最大的容量,范围最广
			//tem <= sum[1]说明所有的行都放不下了,没必要更新
			if (tem <= sum[1]) {
				update(tem, 1, N, 1);
			}
			else {
				len++;  //注意跳过
			}
		}
		for (int i = 0; i < n; i++) {
			printf("%d\n", ans[i]);
		}
	}
	return 0;
}



你可能感兴趣的:(线段树,hduoj)