hdu1525 Euclid's Game

Euclid's Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1437 Accepted Submission(s): 662


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.


Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.


Sample Input
   
   
   
   
34 12 15 24 0 0

Sample Output
   
   
   
   
Stan wins Ollie wins
如果, a>b+b,那么,先手就一定可以胜,否则就只有一种选择!
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int a,b,ans;
    while(scanf("%d%d",&a,&b)!=EOF&&a+b){
        ans=1;
        if(a<b)swap(a,b);
        while(1){
            if(a==b||a>=b+b)break;
            a=a-b;swap(a,b);ans^=1;
        }
        if(ans)printf("Stan wins\n");
        else printf("Ollie wins\n");
    }
    return 0;
}


你可能感兴趣的:(hdu1525 Euclid's Game)