HDU1251(字典树)

统计难题

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 29250 Accepted Submission(s): 11478

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output
对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input
banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output
2
3
1
0

Author
Ignatius.L

最简单的字典树,在节点里加一个计数的就OK了。
#include "cstring"
#include "cstdio"
#include "cstring"
#include "string.h"
using namespace std;
typedef struct node
{
    node *next[26];
    int cnt;
    node()
    {
        cnt=0;
        memset(next,NULL,sizeof(next));
    }
}node;
node *root=new node();
void ins(char s[])
{
    node *now=root;
    for(int i=0;i<strlen(s);i++)
    {
        if(now->next[s[i]-'a']==NULL)
        {
            now->next[s[i]-'a']=new node();
            now->cnt++;
            now=now->next[s[i]-'a'];
        }
        else
        {
            now->cnt++;
            now=now->next[s[i]-'a'];
        }
    }
    now->cnt++;
}
int find(char pat[])
{
    int cnt=0;
    node *now=root;
    for(int i=0;i<strlen(pat);i++)
    {
        if(now->next[pat[i]-'a']==NULL)
            return 0;
        now=now->next[pat[i]-'a'];
    }
    return now->cnt;
}
int main()
{
    char s[15];
    while(gets(s),*s)
        ins(s);
    while(~scanf("%s",s))
        printf("%d\n",find(s));
}

你可能感兴趣的:(HDU1251(字典树))